Announcement

#1 2019-02-14 15:09:19

reinierdeman
Member
2019-02-14
1

Mobile view does not work on my Huawei 10 Pro.

Hello/Hi/Greetings,

My website always worked on my mobile Samsung S5 mini (Android 6).
It does not work properly in mobile view on my Huwei 10 Pro (Android 9) when using the following browsers: Chrome, Opera, Samsung Internet.

The problem: The opening page is fine, showing the different albums. Once I click on the album, there are no thumbnails present. Only by switching to desktop view, will I see the thumbnails. I never had these problems on my old mobile S5 mini.


For some reason, the problem does not appear in Firefox mobile.
Is it a Android problem? Or something to do with my piwigo site?





Piwigo version: 2.9.4
PHP version: 5.5.38
MySQL version: unknown
Piwigo URL: https://rdeman.nl/photos/ [please log in as gast / opbezoek ]

Offline

 

#2 2019-03-24 19:31:00

balthes
Member
2018-10-09
2

Re: Mobile view does not work on my Huawei 10 Pro.

Same problem with Xiaomi Mi Max 3 Phone, Browser: Chrome: Standard view works, but mobile view does not show any pictures. While entering the album in the browser, the nginx (httpd) does not show any access to the thumbs (in Standard view it does):

access.log for not working mobile view from Xiaomi Mi Max 3 (Android 9):
XX.XX.XX.XX - - [24/Mar/2019:19:28:10 +0100] "GET /index.php?/category/2 HTTP/1.1" 200 2548 "http://XXXXXX.com/index.php?/category/1" "Mozilla/5.0 (Linux; Android 9; MI MAX 3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.75 Mobile Safari/537.36"

access.log for working mobile view from Samsum Galaxy (Android 8):
XX.XX.XX.XX - - [24/Mar/2019:20:12:01 +0100] "GET /index.php?/category/2/start-15 HTTP/1.1" 200 2414 "http://XXXXXX.com/index.php?/category/2" "Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/8.2 Chrome/63.0.3239.111 Mobile Safari/537.36"
XX.XX.XX.XX - - [24/Mar/2019:20:12:01 +0100] "GET /_data/i/upload/2019/03/23/20190323175202-67126552-2s.jpg HTTP/1.1" 200 19113 "http://XXXXXX.com/index.php?/category/2/start-15" "Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/8.2 Chrome/63.0.3239.111 Mobile Safari/537.36"
XX.XX.XX.XX - - [24/Mar/2019:20:12:01 +0100] "GET /_data/i/upload/2019/03/23/20190323175201-db2a7568-2s.jpg HTTP/1.1" 200 24190 "http://XXXXXX.com/index.php?/category/2/start-15" "Mozilla/5.0 (Linux; Android 8.0.0; SAMSUNG SM-G935F Build/R16NW) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/8.2 Chrome/63.0.3239.111 Mobile Safari/537.36"
...


    Piwigo 2.9.4
    Operating system: Linux
    PHP: 7.0.33-0+deb9u2 (Show info) [2019-03-24 19:16:42]
    MySQL: 5.5.5-10.1.26-MariaDB-0+deb9u1 [2019-03-24 19:16:42]
    Graphics Library: External ImageMagick 6.9.7-4

Last edited by balthes (2019-03-24 20:19:35)

Offline

 

#3 2019-03-27 14:28:13

Undergrid
Member
2019-03-13
16

Re: Mobile view does not work on my Huawei 10 Pro.

Do you both have the "Smart Pocket (Mobile)" theme activated?  I seem to remember find it didn't work in later Chrome/Android O combinations.

Offline

 

#4 2019-03-27 15:37:34

balthes
Member
2018-10-09
2

Re: Mobile view does not work on my Huawei 10 Pro.

Yes, in my case it is the "Smart Pocket (Mobile)", which does not work. Is there an alternative or workaround?

Offline

 

#5 2019-03-27 16:35:41

Undergrid
Member
2019-03-13
16

Re: Mobile view does not work on my Huawei 10 Pro.

bootstrap_darkroom is responsive and works pretty well on mobile devices, but it'll take over as your main theme too.

Offline

 

#6 2019-07-12 15:03:07

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13223

Re: Mobile view does not work on my Huawei 10 Pro.

[Github] Piwigo commit ad6e96b8

problem fixed for Piwigo 2.10

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact