Announcement

#1 2020-04-12 20:05:09

sadrobot
Member
2018-07-16
6

New plugin Piwigo4blog

Hello,

Uploaded new plugin: https://piwigo.org/ext/extension_view.php?eid=891

It allows to mass export images from Piwigo gallery wrapped in html tags to embed to blog post.

please, take a look

Offline

 

#2 2020-04-13 13:52:01

Katryne
Member
2016-12-03
37

Re: New plugin Piwigo4blog

Hi !
Thanks for the idea which should be useful.
Maybe should work better with my language (French), but do not know how to add it. I juste get a blank page on admin side and cannot see anything to use it on picture and album page.
Can you help ?


https://photos.revestou.fr/  - http://photos.katrynou.fr/
Piwigo 2.10.1 -  OS : Linux - Hosting provider 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Graphic library: External ImageMagick 6.8.9-9

Offline

 

#3 2020-04-13 16:41:50

sadrobot
Member
2018-07-16
6

Re: New plugin Piwigo4blog

Hi! Thanks for feedback. This plugin currently supports only English language. There not too much things to translate, though.

> I juste get a blank page on admin side and cannot see anything to use it on picture and album page.

The whole interface is made with ReactJS framework, so it fully relies on JavaScript. Blank screen might mean that something went wrong with JS. Please make sure you have enabled JavaScript. If it is, please check browser log

In Chrome this should be in browser menu > additinal tools > development tools > Console. There should some kind of error message. Please, post it here, I will check.

Offline

 

#4 2020-04-13 17:10:15

Katryne
Member
2016-12-03
37

Re: New plugin Piwigo4blog

Hi again !
Javascript is enabled.
I enabled error display in LocalFileEditor.
I connected in English.
I tried with 4 different browsers. Under windows10. (I do not use Chrome)
And still the blank page for plugin config. Well not quite blank, I get :

Piwigo4blog plugin
Mass export images from gallery wrapped in html tags to embed to blog post

And white page below

Piwigo 2.10.2
Operating system: Linux
PHP: 7.2.29-1+0~20200320.39+debian8~1.gbp513c2e
MySQL: 5.7.29 [2020-04-13 16:58:33]
Graphics Library: ImageMagick 6.8.9-9

Site is a test site : https://gabandjo.legtux.org/piwigo/

Last edited by Katryne (2020-04-13 17:11:10)


https://photos.revestou.fr/  - http://photos.katrynou.fr/
Piwigo 2.10.1 -  OS : Linux - Hosting provider 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Graphic library: External ImageMagick 6.8.9-9

Offline

 

#5 2020-04-14 19:11:07

sadrobot
Member
2018-07-16
6

Re: New plugin Piwigo4blog

Hello,

I think I have found the reason. This is due to you have your piwigo instanse is opened like https://gabandjo.legtux.org/piwigo/ (with "piwigo" subfolder after domain name) on not like site root (like https://gabandjo.legtux.org/ - this is what I have tested).

I have made some changes that should make plugin work (if my assumption is correct) also in your case. Please try a newer version: 0.1.0-bt2.

Offline

 

#6 2020-04-23 15:33:16

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13300

Re: New plugin Piwigo4blog

Very interesting plugin. It still does not work with localhost/piwigo but it works when Piwigo is on root domain.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2020 · Contact