Piwigo 2.3.3 Release Notes

Downloads Piwigo 2.3.3
Released on February 14th, 2012 (2012-02-14)
Focus new language, bug fixes and minor features
md5sum a35d22a03699708a600332b3a3e6bde8

Note: the list of major changes is described on Piwigo 2.3.0 release notes. This page only describes what changes between release 2.3.2 and release 2.3.3.

Languages

Welcome to a new language, increasing the number of supported languages to 46: Esperanto was added thanks to Axel Rousseau

Several languages were updated to improve wordings or translate strings introduced in Piwigo 2.3 :ភាសាខ្មែរ (Cambodia), Українська (Ukrainian), Afrikaans, العربية (Arabic/Saudi), Deutsch (German), Ελληνικά (Greek), Български (Bulgarian), Castellano (Argentina), Español (Spanish), Estonian, فارسی (Persian), Hrvatski (Croatian), 日本語 (Japanese), Slovenšcina (Slovenia), Српски (Serbia), ภาษาไทย (Thai)

Features Added

  • 0002486: [other] Add an admin view for rates by user
  • 0002566: [web API] [pwg.images.add] ability to update a photo

Bugs Fixed

  • 0002551: [configuration] Wrong gallery URL in notification by mail
  • 0000559: [metadata] duplicate insert on tags when synchronizing metadata
  • 0002540: [configuration] When default photos order is only by rank, failure outside albums
  • 0002552: [other] Apply trigger render_element_description for thumbnail title (for picture description)
  • 0002546: [users & groups] ghost user/group created on album permission manager
  • 0002543: [web API] [pwg.categories.getList] missing album thumbnail

Upgrade

Recommended method: follow the automatic upgrade procedure. If you're currently running Piwigo 2.2, the Automatic Upgrade will tell you which plugin may be not compatible with Piwigo 2.2 before upgrade.

If you're running Piwigo 2.3.0, 2.3.1 or 2.3.2 you can also download the 2.3.x_to_2.3.3.zip archive that contains all new and modified files. Once you have extracted the files, transfer them onto your web server with a FTP client (like FileZilla) over your Piwigo 2.3.x installation. No database upgrade is required.

If you are running a version older than 2.3.0 and do not want to use the automatic upgrade, then follow the manual upgrade.

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact