Announcement

#1 2020-02-14 07:27:48

claidheamdanns
Member
Memphis
2020-02-09
11

Image Sizes Not Generated

Greetings,

I just switched over to Piwigo this past week, from Menalto, and finished uploading all my photos. I'm getting a lot of missing images (question mark where there should be an image).

Here's an example: https://or-lcthf.org/photos/picture.php … ategory/47

The full size image is there, and even some of the other sizes, but not the default Medium size. I tried rebuilding the image versions, but that didn't seem to help.

This is happening with a lot of images, and different size images are missing, not the same size on each photo.

Piwigo version: 2.10.1
PHP version: 5.6.30
MySQL version: 5.6.41-84.1-log
Piwigo URL: https://or-lcthf.org/photos

Offline

 

#2 2020-02-14 15:59:48

erAck
Only trying to help
2015-09-06
1415

Re: Image Sizes Not Generated

https://or-lcthf.org/photos/i.php?/uplo … 98c-me.jpg gives
"cannot be displayed because it contains errors".
Same for the other blank (for me, not a question mark) images.


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2020-03-03 07:06:40

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

I'm not sure I understand your reply. Are you saying that there is an error with the photo itself?

When I go to sizes, and view other sizes of the photos in question, including the original size, they show up fine.

But if you are talking about the i.php resource, is that something I can fix on my side? I thought that was part of the program.

Last edited by claidheamdanns (2020-03-03 07:13:38)

Offline

 

#4 2020-03-03 09:10:33

erAck
Only trying to help
2015-09-06
1415

Re: Image Sizes Not Generated

I was talking about the thumbnail image file I linked. It appears to be broken. Other thumbnail sizes' image files and the original photo may be ok, yes. Apparently you have broken thumbnail image files on disk. This file's size seems to be 0 bytes.


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2020-03-04 01:19:45

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

Yes, that’s exactly what I was reporting. These thumbnails are generated by piwigo. The full size original is fine, and even some of the other sizes are, but not that size. When I go into maintenance and have it regenerate those sizes, they still come up wrong.

Offline

 

#6 2020-03-04 03:07:01

erAck
Only trying to help
2015-09-06
1415

Re: Image Sizes Not Generated

Are the broken thumbnail files actually regenerated or are they still the old 0 bytes files? i.e. after generating thumbnails, is the file's modification time new? You don't accidentally run out of disk quota? Or hit some run time or memory limit?


Running Piwigo at https://erack.net/gallery/

Offline

 

#7 2020-03-04 03:42:25

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

I don’t know the answer to the first part. I’ll have to check and see.

Answer to the second part is that I have unlimited server space on a premium plan.

Offline

 

#8 2020-03-05 03:24:20

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

I can't find any way to get modification date info on the broken thumbnails, since they aren't actually images, but the lack thereof. I've even tried deleting one of the photos in question and re-uploading it from scratch, with the same results as before.

Offline

 

#9 2020-03-05 14:52:45

erAck
Only trying to help
2015-09-06
1415

Re: Image Sizes Not Generated

The modification date of the file I meant (e.g. when viewing with ls -l or in a file manager). Of course there's no image information in a 0 byte file..


Running Piwigo at https://erack.net/gallery/

Offline

 

#10 2020-04-23 03:34:35

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

Sorry to get back to you so belatedly. As a webmaster, the coronavirus hit my workload hard!!

I'm trying to look up the information you are requesting in my Transmit FTP Browser. Just a sec.

Meanwhile, I noticed something interesting about the error files. When I go to the thumbnail for a working photo, the address looks like this:
The gallery page: http://or-lcthf.org/photos/picture.php?/6/category/17
Open image in new window: http://or-lcthf.org/photos/_data/i/upload/2020/02/08/20200208214209-f391e0db-me.jpg

But on the files that don't work:
The gallery page: http://or-lcthf.org/photos/picture.php?/3/category/17
Open image in new window: http://or-lcthf.org/photos/i.php?/upload/2020/02/08/20200208214151-a59c5e9b-me.jpg

So, there is a difference in the structure of the address.

Looking for that file (20200208214151-a59c5e9b-me.jpg) on the FTP server shows that it doesn't exist there, although 2s, cu_e250, sq, and xs versions of the file do exist, with varying modification dates. I'm attaching a screen shot of that which will hopefully answer your question. Also a shot of what's up there after I regenerated all images, so you can see that it regenerated some, but not all images.

Last edited by claidheamdanns (2020-04-23 03:38:04)

Offline

 

#11 2020-04-24 06:00:29

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

I uploaded 745 photos to my customer's gallery last night, and didn't have trouble with a single one.

When I checked out the originals of all the ones that they uploaded and were having trouble with, the photos were huge! (see screenshot) When I downsized them in Photoshop (not as small as the ones I uploaded, but to the size of the maximum file that worked correctly), they uploaded fine. (see screenshot of resized photo, and also screenshot of the dimensions of the photos I uploaded)

So, if I set a size limit on their uploads (if there is a way to do that), maybe that will solve everything?

Offline

 

#12 2020-05-26 20:36:16

Gapster
Member
Boston
2017-10-06
8

Re: Image Sizes Not Generated

Hello claidheamdanns,

Your issue looks similar to mine(https://piwigo.org/forum/viewtopic.php?id=30297), was wondering if you found a work around?

I don't think mine is a size issue.

Thanks!

Offline

 

#13 2020-05-30 15:54:02

claidheamdanns
Member
Memphis
2020-02-09
11

Re: Image Sizes Not Generated

Nope, no solution found yet for me, except manually reducing the size of every image before uploading … which is no solution at all.

Offline

 

#14 2020-05-30 17:12:11

Gapster
Member
Boston
2017-10-06
8

Re: Image Sizes Not Generated

Thanks for the reply.  I think we had different issues. I was able to fix my issue by installing the privacy module.  I think I installed that awhile ago and then uninstalled it, so reinstalling it fixed my issue.

Take care!

Offline

 

#15 2020-05-30 19:37:39

executive
Member
2017-08-16
1099

Re: Image Sizes Not Generated

which graphics library is Piwigo using? (Tools>Maintenance)

You should have a look here:

https://piwigo.org/doc/doku.php?id=user … es_missing

Particularly, 2.1.VI, and 2.2

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact