Announcement

#1 2012-06-25 16:24:04

rbr28
Member
Bloomington, IN USA
2010-07-13
35

exif data ...again

The Advanced Metadata plugin no longer works with Piwigo 2.4 but it seems like there is some support for displaying exif data with the php extension.  I have the php extension enabled, but the only exif displayed for my images is Make, Model, Date, Aperture.  Is  there a file I can edit to change exactly what data is displayed and/or the order?

Still would love to see the option to read exif to tags in the database.  It would be nice to be able to have virtual albums and/or search by parameters such as the lens.

Thanks,
Vern

Offline

 

#2 2012-06-29 03:22:09

rbr28
Member
Bloomington, IN USA
2010-07-13
35

Re: exif data ...again

I did find the Metadata documentation which explained a bit about how exif data is handled.  The documentation I found refers to branch 1.3 and 1.4.  Is the documentation that old or is it supposed to refer to 2.3 and 2.4?  In any event the information was helpful but it just confirms what I have always found, that the base functionality isn't sufficient (which is why I always loved the Advanced Metadata extension).

I'd have to do a lot of additional coding to use the base functionality.  I have photos from multiple cameras and the exif data is different for all of them.  As an example, my Nikon camera uses a bizarre notation for shutterspeed, with everything being a multiple of ten, like 10/600 instead of 1/60s.  I'd have to put a calculation in the code for that, but since I have multiple cameras I'd have to do determine the model, and then do a different calculation for each one.  I'm not a programmer and I've seen in other galleries such as Gallery2 and Gallery3, how the exif code is written, and that's definitely not something I'd want to tackle, mostly due to lack of time rather than lack of interest.  Not a big deal but I hope the Advanced Metadata plugin gets updated for 2.4!

Vern

Offline

 

#3 2012-06-29 09:32:51

flop25
Piwigo Team
2006-07-06
6965

Re: exif data ...again

rbr28 wrote:

I did find the Metadata documentation which explained a bit about how exif data is handled.  The documentation I found refers to branch 1.3 and 1.4.  Is the documentation that old or is it supposed to refer to 2.3 and 2.4?

yes the english documentation has huge lack... you can the french using translation tools, but we are trying to translate the most important documentation : see [Forum, topic 19375] List of Wiki pages which need a review from native English speakers

rbr28 wrote:

Not a big deal but I hope the Advanced Metadata plugin gets updated for 2.4!

the best way is the winsomeness by waiting ^^


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#4 2014-10-04 14:28:03

vw
Guest

Re: exif data ...again

Has there been any more progress on the documentation for using piwigo's built in functionality for displaying exif data?  AMetadata has become more broken with each version, but without it I've only been able to display a very limited amount of photo metadata.

 

#5 2014-10-07 09:16:56

SnotRocket
Member
2014-08-15
63

Re: exif data ...again

Just curious...

What exif info are you missing?

I'm running 2.7 and have a bunch of EXIF info.

http://2000transam.com/upload/10-7-20142-13-38AM.jpg

All I've done is edit my local config with:

$conf['show_exif_fields'] = array(
  'Make',
  'Model',
  'ExifVersion',
  'Software',
  'DateTimeOriginal',
  'FNumber',
  'ExposureBiasValue',
  'FILE;FileSize',
  'ExposureTime',
  'Flash',
  'ISOSpeedRatings',
  'FocalLength',
  'FocalLengthIn35mmFilm',
  'WhiteBalance',
  'ExposureMode',
  'MeteringMode',
  'ExposureProgram',
  'LightSource',
  'Contrast',
  'Saturation',
  'Sharpness',
  );



I realize that it's not perfect.. but it's not bad.

Last edited by SnotRocket (2014-10-07 09:18:18)

Offline

 

#6 2014-10-07 16:12:48

Vw
Guest

Re: exif data ...again

Thanks for that sample.  I found some documentation about the fields that could be used, but I wasn't sure what code to put where.  All I had was the default which was aperture only.  I put that sample in my config and can work on just tweaking that some now.

 

#7 2014-10-07 16:16:18

SnotRocket
Member
2014-08-15
63

Re: exif data ...again

If you add the exif extension back in after adding the code, things like FNumber, etc, actually show as they are supposed to (f/2.8, etc).

I had to disable it because it had an odd conflict with batch manager and wouldn't allow me to batch create images...

I've since turned it back on and it works fine.

http://2000transam.com/upload/10-7-20149-17-15AM.jpg

Last edited by SnotRocket (2014-10-07 16:18:27)

Offline

 

#8 2014-10-09 00:56:09

Vw
Guest

Re: exif data ...again

Mine still displays like your initial post, even after disabling and enabling the exif extension.  I used COMPUTED;ApertureFNumber for aperture and that displays correctly, everything else displays just like your first example.

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact