Announcement

#1 2018-01-16 00:26:21

tomsmig
Member
2014-08-01
12

Mediainfo error

Hi, I have installed Video-JS plugin and configured mediainfo and ffmpeg, but mediainfo does not read movie properties.

After synchronizing gallery I have this kind of error:
"Mediainfo error reading file: './galleries/Festiwal_kultury_chinskiej/00003.m4v'"

ffmpeg works in Video-JS plugin good, for example:
"file: ./galleries/Festiwal_kultury_chinskiej/00003.m4v
  poster: ./galleries/Festiwal_kultury_chinskiej/pwg_representative/00003.jpg"

Run mediainfo from CLI works good:
mediainfo --Full --Output=XML --Language=raw './galleries/Festiwal_kultury_chinskiej/00003.m4v'

[root@localhost piwigo]# mediainfo --Full --Output=XML --Language=raw './galleries/Festiwal_kultury_chinskiej/00003.m4v'
<?xml version="1.0" encoding="UTF-8"?>
<MediaInfo
    xmlns="https://mediaarea.net/mediainfo"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="https://mediaarea.net/mediainfo https://mediaarea.net/mediainfo/mediainfo_2_0.xsd"
    version="2.0">
<creatingLibrary version="17.12" url="https://mediaarea.net/MediaInfo">MediaInfoLib</creatingLibrary>
<media ref="./galleries/Festiwal_kultury_chinskiej/00003.m4v">
<track type="General">
<VideoCount>1</VideoCount>
<AudioCount>2</AudioCount>
<FileExtension>m4v</FileExtension>
<Format>MPEG-4</Format>
<Format_Profile>Base Media / Version 2</Format_Profile>
<CodecID>mp42</CodecID>
<FileSize>108090784</FileSize>
<Duration>100.395</Duration>
<OverallBitRate_Mode>VBR</OverallBitRate_Mode>
<OverallBitRate>8613240</OverallBitRate>
<FrameRate>25.000</FrameRate>
<FrameCount>2508</FrameCount>
<StreamSize>86760</StreamSize>
<HeaderSize>86752</HeaderSize>
<DataSize>108004032</DataSize>
<FooterSize>0</FooterSize>
<IsStreamable>Yes</IsStreamable>
<Encoded_Date>UTC 2018-01-14 22:23:11</Encoded_Date>
<Tagged_Date>UTC 2018-01-14 22:23:11</Tagged_Date>
<File_Modified_Date>UTC 2018-01-14 22:27:32</File_Modified_Date>
<File_Modified_Date_Local>2018-01-14 23:27:32</File_Modified_Date_Local>
<Encoded_Application>HandBrake 1.0.7 2017040900</Encoded_Application>
</track>

<track type="Video">
<StreamOrder>0</StreamOrder>
<ID>1</ID>
<Format>AVC</Format>
<Format_Profile>High</Format_Profile>
<Format_Level>4</Format_Level>
<Format_Settings_CABAC>Yes</Format_Settings_CABAC>
<Format_Settings_RefFrames>5</Format_Settings_RefFrames>
<CodecID>avc1</CodecID>
<Duration>100.320</Duration>
<BitRate>8196289</BitRate>
<Width>1440</Width>
<Height>1080</Height>
<Stored_Height>1088</Stored_Height>
<Sampled_Width>1440</Sampled_Width>
<Sampled_Height>1080</Sampled_Height>
<PixelAspectRatio>1.333</PixelAspectRatio>
<DisplayAspectRatio>1.778</DisplayAspectRatio>
<Rotation>0.000</Rotation>
<FrameRate_Mode>CFR</FrameRate_Mode>
<FrameRate_Mode_Original>VFR</FrameRate_Mode_Original>
<FrameRate>25.000</FrameRate>
<FrameCount>2508</FrameCount>
<ColorSpace>YUV</ColorSpace>
<ChromaSubsampling>4:2:0</ChromaSubsampling>
<BitDepth>8</BitDepth>
<ScanType>Progressive</ScanType>
<StreamSize>102781460</StreamSize>
<Encoded_Library>x264 - core 148 r2708 86b7198</Encoded_Library>
<Encoded_Library_Name>x264</Encoded_Library_Name>
<Encoded_Library_Version>core 148 r2708 86b7198</Encoded_Library_Version>
<Encoded_Library_Settings>cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dc                                                    t=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained                                                    _intra=0 / bframes=5 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=30                                                     / rc=crf / mbtree=1 / crf=18.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00</Encoded_Library_Settings>
<Encoded_Date>UTC 2018-01-14 22:23:11</Encoded_Date>
<Tagged_Date>UTC 2018-01-14 22:23:11</Tagged_Date>
<colour_range>Limited</colour_range>
<colour_description_present>Yes</colour_description_present>
<colour_primaries>BT.709</colour_primaries>
<transfer_characteristics>BT.709</transfer_characteristics>
<matrix_coefficients>BT.709</matrix_coefficients>
</track>

<track type="Audio" typeorder="1">
<StreamOrder>1</StreamOrder>
<ID>2</ID>
<Format>AAC</Format>
<Format_Profile>LC</Format_Profile>
<Format_Settings_SBR>No (Explicit)</Format_Settings_SBR>
<CodecID>mp4a-40-2</CodecID>
<Duration>100.395</Duration>
<BitRate_Mode>VBR</BitRate_Mode>
<BitRate>160189</BitRate>
<Channels>2</Channels>
<ChannelPositions>Front: L R</ChannelPositions>
<ChannelLayout>L R</ChannelLayout>
<SamplesPerFrame>1024</SamplesPerFrame>
<SamplingRate>48000</SamplingRate>
<SamplingCount>4818960</SamplingCount>
<FrameRate>46.875</FrameRate>
<FrameCount>4706</FrameCount>
<Compression_Mode>Lossy</Compression_Mode>
<StreamSize>2010276</StreamSize>
<StreamSize_Proportion>0.01860</StreamSize_Proportion>
<Title>Stereo / Stereo</Title>
<Default>Yes</Default>
<AlternateGroup>1</AlternateGroup>
<Encoded_Date>UTC 2018-01-14 22:23:11</Encoded_Date>
<Tagged_Date>UTC 2018-01-14 22:23:11</Tagged_Date>
<extra>
<Fallback_From>3</Fallback_From>
</extra>
</track>

<track type="Audio" typeorder="2">
<StreamOrder>2</StreamOrder>
<ID>3</ID>
<Format>AC-3</Format>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>ac-3</CodecID>
<Duration>100.384</Duration>
<BitRate_Mode>CBR</BitRate_Mode>
<BitRate>256000</BitRate>
<Channels>2</Channels>
<ChannelPositions>Front: L R</ChannelPositions>
<ChannelLayout>L R</ChannelLayout>
<SamplesPerFrame>1536</SamplesPerFrame>
<SamplingRate>48000</SamplingRate>
<SamplingCount>4818432</SamplingCount>
<FrameRate>31.250</FrameRate>
<FrameCount>3137</FrameCount>
<BitDepth>16</BitDepth>
<Compression_Mode>Lossy</Compression_Mode>
<StreamSize>3212288</StreamSize>
<StreamSize_Proportion>0.02972</StreamSize_Proportion>
<Title>Stereo / Stereo</Title>
<ServiceKind>CM</ServiceKind>
<Default>Inherited From: 2</Default>
<AlternateGroup>1</AlternateGroup>
<Encoded_Date>UTC 2018-01-14 22:23:11</Encoded_Date>
<Tagged_Date>UTC 2018-01-14 22:23:11</Tagged_Date>
<extra>
<Fallback_To>2</Fallback_To>
<bsid>4</bsid>
<dialnorm>-31</dialnorm>
<dialnorm_String>-31 dB</dialnorm_String>
<compr>-5.00</compr>
<compr_String>-5.00 dB</compr_String>
<dsurmod>0</dsurmod>
<acmod>2</acmod>
<lfeon>0</lfeon>
<dialnorm_Average>-31</dialnorm_Average>
<dialnorm_Average_String>-31 dB</dialnorm_Average_String>
<dialnorm_Minimum>-31</dialnorm_Minimum>
<dialnorm_Minimum_String>-31 dB</dialnorm_Minimum_String>
<dialnorm_Maximum>-31</dialnorm_Maximum>
<dialnorm_Maximum_String>-31 dB</dialnorm_Maximum_String>
<dialnorm_Count>32</dialnorm_Count>
<compr_Average>-6.21</compr_Average>
<compr_Average_String>-6.21 dB</compr_Average_String>
<compr_Minimum>-7.18</compr_Minimum>
<compr_Minimum_String>-7.18 dB</compr_Minimum_String>
<compr_Maximum>-5.00</compr_Maximum>
<compr_Maximum_String>-5.00 dB</compr_Maximum_String>
<compr_Count>32</compr_Count>
</extra>
</track>

</media>
</MediaInfo>


Mediainfo was installed with command:
"rpm -Uvh https://mediaarea.net/repo/rpm/releases … .rpm"

Checking version:
mediainfo --version
MediaInfo Command line, MediaInfoLib - v17.12

I can run mediainfo as regular user from cli with no problems at all.

Piwigo version: 2.9.2
PHP version: 5.4.16
MySQL version: mysql  Ver 15.1 Distrib 5.5.56-MariaDB, for Linux (x86_64) using readline 5.1

Last edited by tomsmig (2018-01-16 00:31:04)

Offline

 

#2 2018-01-17 00:48:42

tomsmig
Member
2014-08-01
12

Re: Mediainfo error

I think that error appears because of mediainfo version that is supported by plugin.
On CentOS (and other recent distributions) mediainfo (v17.12)  has XML output format, that is not covered by this plugin.
Looks like only xbgmsharp can help here ;/

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact