Announcement

#31 2019-10-16 10:01:17

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13338

Re: "Some checksums are missing." after upgrade to 2.10

windracer wrote:

plg wrote:

windracer wrote:

After I upgraded to 2.10.1, the "some checksums are missing" message is gone from my dashboard. Thanks!

you will find it again on page [Administration > Tools > Synchronize] ;-)

Yep, actually I just noticed that. So that's expected?

Yes. Photos added with FTP+sync have no md5sum. They never had. As you know, it didn't prevent Piwigo from working fine :-)

Offline

 

#32 2019-10-16 15:45:19

windracer
Member
St. Pete, FL
2014-12-28
268

Re: "Some checksums are missing." after upgrade to 2.10

plg wrote:

Yes. Photos added with FTP+sync have no md5sum. They never had. As you know, it didn't prevent Piwigo from working fine :-)

After upgrading to 2.10.1 I was able to run the checksums from the sync page and this time they all created so the message is gone now.

Offline

 

#33 2019-10-19 11:38:31

karolox
Member
2019-10-12
9

Re: "Some checksums are missing." after upgrade to 2.10

Hello.
I have a problem. I can't select all and edit photos.

An error:
Notice: Undefined index: checksum_compute_blocksize in /home/html/hmyzslovenska.info/public_html/admin/batch_manager_global.php on line 461

I use Piwigo 2.10.1
www.hmzyslovenska.info

Thank you for your help. Regards Karol.

Offline

 

#34 2020-04-19 12:18:22

martinis
Member
2013-07-02
28

Re: "Some checksums are missing." after upgrade to 2.10

I have also started getting this message after an upgrade, exactly as described by the OP
Now at:

    Piwigo 2.10.2 Check for upgrade
    Operating system: Linux
    PHP: 7.2.24 (Show info) [2020-04-19 11:02:49]
    MySQL: 5.5.5-10.2.31-MariaDB-log [2020-04-19 06:02:49]
    Graphics Library: External ImageMagick 6.7.8-9

When I try to obtain the checksums using the link provided in the batch manager, then something seems to be going on but it stays at 0% for some time, and finally ends with an 'ERROR 200 : OK' message. The procedure can be repeated several times with no change.

I upload all photos directly and use FTP+sync, so maybe I just ignore this message?  [NB I have tried the suggestion of turning off 'js/css combine' but this has no effect]

However, I have a mirror of the website on my local machine and this was able to get through the problem to 100%, suggesting the live version on my shared hosting has a resource limit which is being reached.

So my question is this: Is this a bug which I can safely ignore on my live site? If not, what can I do, and is there anything on my local site that I could use (eg a file which can be FTP) to fix it?

Thanks for your help.

Offline

 

#35 2020-04-21 16:05:36

martinis
Member
2013-07-02
28

Re: "Some checksums are missing." after upgrade to 2.10

Further to this, it is clear that the md5sum fields are all NULL in the Piwigo database, and the software must be trying to calculate them.  There are around 2000 checksums to obtain

I see from my hosting panel metrics that I am reaching my I/O limits of 4Mb/sec, which will explain why the procedure is never completed.

As I use FTP+Sync for all photos, I understand that I can manage without the checksums (?). But, as I have read on github, it has been suggested that having such an error message is off-putting. Can I suggest that there is either some way of doing the checksums in stages and/or a warning message is given, especially relevant to those on shared web hosting.

Many thanks

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2020 · Contact