Announcement

#1 2019-12-11 14:10:10

pert
Member
2016-02-14
9

[resolved] Some pictures are not shown after upgrade to Piwigo 2.10.1

Hi,
upgraded automatically today. Afterwards experienced problems viewing  some pictures.

Did a manual update:
downloaded the update
unzipped
transferred the files with ftp

All plug-ins are inactivated.

Unfortunately, I still cannot see all pictures.

Using the theme "elegant":

gif-files are only visible as thumbnails
some jpeg-files are not visible
jpeg-files in some albums are not visible

If I use the new default theme "modus" I cannot even see the thumbnails!
The albums are just shown as text.

Piwigo version: 2.10.1
PHP version: 7.1.21
MySQL version: working on that!

Yours,
Per Tunedal

Last edited by pert (2019-12-12 11:05:22)

Offline

 

#2 2019-12-11 14:31:10

pert
Member
2016-02-14
9

Re: [resolved] Some pictures are not shown after upgrade to Piwigo 2.10.1

Hi again;
MySQL-version: MariaDB 5.5.5.2
Yours,
Per Tunedal

Offline

 

#3 2019-12-11 16:42:57

pert
Member
2016-02-14
9

Re: [resolved] Some pictures are not shown after upgrade to Piwigo 2.10.1

Hi,
I've tried an update to PHP 7.2.9 but that didn't help. It works just the same.

Tried to activate the plug-in "Image Preview" and it works. I can see a preview of the missing pictures when hoovering over the thumbnail. Clicking on the thumbnail produces an empty page showing the filename.

Changing to the theme "modus" makes nothing work, as before.

Changing image size when viewing an image doesn't work. Most sizes will result in an empty page. If I choose "original" size I get an error message "Access denied". Only "medium" works.

Yours,
Per Tunedal

Offline

 

#4 2019-12-11 17:23:36

jnashpiwigo
Piwigo Team
2014-10-21
236

Re: [resolved] Some pictures are not shown after upgrade to Piwigo 2.10.1

I'd check the permissions of your _data directory and subdirectories (these should be read/write for the web user)

You may have inadvertently changed the permissions when you FTP'd over the updates

Last edited by jnashpiwigo (2019-12-11 17:25:27)

Offline

 

#5 2019-12-11 22:34:28

pert
Member
2016-02-14
9

Re: [resolved] Some pictures are not shown after upgrade to Piwigo 2.10.1

Thank you jnashpiwigo! You put me on the right track.

Updating disabled the plug-in "piwigo_privacy ". Enabling it makes everything work as expected.

Apparently, Piwigo has some kind of cache that was used for the pictures that could be displayed. That's potentially a bad thing because it might bypass the efforts made by the  piwigo_privacy plug-in to prevent access for users not logged in.

I will search more information on how the caching works in Piwigo.

Last edited by pert (2019-12-12 11:08:48)

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2021 · Contact