Announcement

  •  » Engine
  •  » Issue when running Maintenance >> Repair and optimise database

#1 2020-03-26 22:41:08

Nigel-Aves
Member
2015-09-22
63

Issue when running Maintenance >> Repair and optimise database

Hello/Hi/Greetings,

I have run into an issue in my gallery, where, if I click a thumbnail the wrong photograph opens up.

So I tried running under Maintenance the "Repair and Optimise Database" function.

it always errors out and at the top of the screen I have this message ....


Warning:  [mysql error 1067] Invalid default value for 'date'
ALTER TABLE piwigo_comments ORDER BY id; in /home/soft-focus-imagining/domains/gallery-adult.soft-focus-imagining.com/public_html/include/dblayer/functions_mysqli.inc.php on line 856

and I don't know if this is a PIWIGO issue or a MySQL issue ....

Any help would be greatly received.

Nigel Aves.

Piwigo 2.10.1
Operating system: Linux
PHP: 7.2.24-0ubuntu0.18.04.3 (Show info) [2020-03-26 15:13:37]
MySQL: 5.7.29-0ubuntu0.18.04.1 [2020-03-26 15:13:37]
Graphics Library: External ImageMagick 6.9.7-4/

Offline

 

#2 2020-03-27 00:01:44

executive
Member
2017-08-16
1216

Re: Issue when running Maintenance >> Repair and optimise database

try adding your time zone to your php.in file.

Offline

 

#3 2020-03-27 00:09:17

Nigel-Aves
Member
2015-09-22
63

Re: Issue when running Maintenance >> Repair and optimise database

Just double checked my php.ini file.

It was set to  America / Denver

Offline

 
  •  » Engine
  •  » Issue when running Maintenance >> Repair and optimise database

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact