Announcement

  •  » Extensions
  •  » Errors when event tracer plugin installed

#1 2020-09-17 22:07:19

dd-b
Member
2018-04-16
63

Errors when event tracer plugin installed

I'm taking the first cautious steps to starting to write my first plugin. I have some PHP experience and a lifetime of software development experience (retired after 50 years in the field). Anyway -- research seemed to suggest that the event tracer plugin was the best way to find out how piwigo core and other plugins work, so my first step was to install this plugin.

As soon as I had it installed, I got these two messages at the top of every page from my site:

Code:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; EventTracer has a deprecated constructor in /home/dh_akhcfg/gal01.dd-b.net/piwigo/plugins/event_tracer/main.inc.php on line 35

Warning: Cannot modify header information - headers already sent by (output started at /home/dh_akhcfg/gal01.dd-b.net/piwigo/plugins/event_tracer/main.inc.php:35) in /home/dh_akhcfg/gal01.dd-b.net/piwigo/include/page_header.php on line 86

That second one, while technically a warning, looks serious -- something being sent as headers isn't going to actually get to the browser, I think that means?

    Piwigo 2.10.2
    Operating system: Linux
    PHP: 7.2.30 (Show info) [2020-09-17 13:04:23]
    MySQL: 5.7.29-log [2020-09-17 13:04:23]
    Graphics Library: ImageMagick 6.9.7-4
    site: http://gal01.dd-b.net/piwigo

Last edited by dd-b (2020-09-17 22:10:43)

Offline

 
  •  » Extensions
  •  » Errors when event tracer plugin installed

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact