Announcement

#1 2021-08-06 17:42:47

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13571

Piwigo 12.0.0beta2

Piwigo 12 gets a new update with a second beta version. Minor new features and many bug fixes.

A) Changes

https://piwigo.org/screenshots/piwigo-12-move-album.gif
A new "move" button goes from the album manager to the album mover.

https://piwigo.org/screenshots/piwigo-12-user-status.png
User edition: let's give details about status.

https://piwigo.org/screenshots/piwigo-12-maintenance-plugin-list.png
Maintenance now displays the list of active plugins.

https://piwigo.org/screenshots/piwigo-12-cache-size.png
Maintenance provides more details about cache size and the ability to refresh it (before purge).

B) Bug fixes and PHP compatibility

Many bugs were fixed. discover them all

Piwigo 12 will require at least PHP 7.0... and Matthieu has checked/fixed compatibility with PHP 8.0 ! (including a big update of Smarty, the template engine Piwigo relies on). So please, test this beta version on your latest PHP version if you can.

C) Start to beta test

Download Piwigo 12.0.0beta2

If you want to test but don't have the ability to install it, contact us.

Please, open a new topic in the beta testing forum for each problem you may encounter.

Happy beta-testing :-)

Offline

#2 2021-08-06 23:26:29

windracer
Member
St. Pete, FL
2014-12-28
375

Re: Piwigo 12.0.0beta2

I had the old 'groups' reserved word issue when trying to upgrade to beta2. After unzipping, when I visited upgrade.php I got this error:

Code:

Piwigo encountered an irrecoverable error
[mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups' at line 1

DESC groups
;

#1  my_error /usr/local/piwigo-beta/include/dblayer/functions_mysqli.inc.php(132)
#2  pwg_query /usr/local/piwigo-beta/upgrade.php(83)
#3  get_columns_of /usr/local/piwigo-beta/upgrade.php(265)

I had to put the $escape_reserved_words workaround (from [Github] AMenuManager issue #5) back into pwg_query in functions_mysqli.inc.php to get it working again.

edit: I see there are updated versions of the Advanced Menu Manager and Grum Plugin Classes extensions, so I updated those, but still got the error from upgrade.php if I took out that workaround code. So not sure if this is a problem I've caused or something else.

Last edited by windracer (2021-08-06 23:40:59)

Offline

#3 2021-08-06 23:33:49

Zentalquabula
Member
2014-05-10
208

Re: Piwigo 12.0.0beta2

PHP 8? Great!

Reserved words? Backticks, people… `groups`

Offline

#4 2021-08-07 00:22:35

erAck
Only trying to help
2015-09-06
1414

Re: Piwigo 12.0.0beta2

windracer wrote:

I had to put the $escape_reserved_words workaround (from [Github] AMenuManager issue #5) back into pwg_query

edit: I see there are updated versions of the Advanced Menu Manager and Grum Plugin Classes extensions, so I updated those, but still got the error from upgrade.php if I took out that workaround code. So not sure if this is a problem I've caused or something else.

You mean you got the error when you first upgraded AMenuManager and after that did the upgrade and you still got an error from an AMenuManager query?


Running Piwigo at https://erack.net/gallery/

Offline

#5 2021-08-07 03:08:18

windracer
Member
St. Pete, FL
2014-12-28
375

Re: Piwigo 12.0.0beta2

erAck wrote:

You mean you got the error when you first upgraded AMenuManager and after that did the upgrade and you still got an error from an AMenuManager query?

No, I upgraded Piwigo first and had the error accessing upgrade.php (and lots of similar errors when trying to get into the Admin area) so I put in the workaround.

After that fixed it, I noticed the updates for AMenuManager and Grum Plug-in Classes and upgraded those. So I tried removing the workaround from functions_mysqli and still had the error, so put the workaround back again.

Offline

#6 2021-08-07 09:30:42

erAck
Only trying to help
2015-09-06
1414

Re: Piwigo 12.0.0beta2

There may be other still broken plugins.


Running Piwigo at https://erack.net/gallery/

Offline

#7 2021-09-28 01:31:58

windracer
Member
St. Pete, FL
2014-12-28
375

Re: Piwigo 12.0.0beta2

I'm still getting the groups error when trying to upgrade to 12.0.0RC1:

Code:

Piwigo encountered an irrecoverable error
[mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups' at line 1

DESC groups
;

#1  my_error /usr/local/piwigo-beta/include/dblayer/functions_mysqli.inc.php(132)
#2  pwg_query /usr/local/piwigo-beta/upgrade.php(83)
#3  get_columns_of /usr/local/piwigo-beta/upgrade.php(265)

What am I doing wrong?

PHP: 7.4.16
MySQL: 8.0.26-0ubuntu0.21.04.3

Last edited by windracer (2021-09-28 01:34:28)

Offline

#8 2021-09-28 12:46:26

erAck
Only trying to help
2015-09-06
1414

Re: Piwigo 12.0.0beta2

Do you by chance have an empty table prefix in your local/config/database.inc.php

$prefixeTable = 'piwigo_';

or no prefixeTable there at all? And your database contains a 'groups' table?

That could explain, because upgrade.php line 265 calls get_columns_of($tables) (which then would have the DESC groups; for that table) and before there's $tables = get_tables(); that obtains all tables matching '/^'.PREFIX_TABLE.'/'

If so, the remedy probably could be to rename all Piwigo tables with a proper prefix and add that prefix to local/config/database.inc.php


Running Piwigo at https://erack.net/gallery/

Offline

#9 2021-09-28 16:25:01

windracer
Member
St. Pete, FL
2014-12-28
375

Re: Piwigo 12.0.0beta2

erAck wrote:

Do you by chance have an empty table prefix in your local/config/database.inc.php

$prefixeTable = 'piwigo_';

or no prefixeTable there at all? And your database contains a 'groups' table?

Ah, that's it. It's blank in database.inc.php and my tables in MySQL do NOT have a prefix on them. So yes, the table name is 'groups'. I think it's been this way since I started using Piwigo ... guess I should do some alters to rename all of the tables with a prefix and then use that.

Thanks!

Offline

#10 2021-09-28 16:50:24

windracer
Member
St. Pete, FL
2014-12-28
375

Re: Piwigo 12.0.0beta2

That fixed it. I altered all my tables to have the pwg_ prefix and then set that in database.inc.php. That resolved the issue.

Offline

#11 2022-06-16 00:35:43

dummer-esel
Member
2017-01-25
51

Re: Piwigo 12.0.0beta2

Sorry to respond to an old post...

erAck wrote:

There may be other still broken plugins.

Are all plugins compatible now with PHP 8?

At least the current stable version seems to be compatible.

But what about my plugins?
Currently I have installed:

Additional Pages
Admin Tools
Advanced Menu Manager
Automatic Size
Block search
Fotorama
Grum Plugins Classes.3
GThumb+
jplayer
Perso Footer
prevnext
Protected Albums
PWG Stuffs
RV Menu Tree
SortOrders

Piwigo 12.2.0
OS: Linux
PHP: 7.4.28 (Info) [2022-06-16 00:34:09]
MySQL: 5.5.5-10.5.15-MariaDB-1:10.5.15+maria~focal-log [2022-06-16 00:34:09]
Graphics library: ImageMagick 6.9.10-23

Offline

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact