Announcement

#1 2021-11-14 13:53:27

Tillgren
Member
2018-11-06
8

Admin-interface doesnt work after upgrade to 12.1

So I did the upgrade to 12.1 but something went wrong. The site tillgrensbilder.com is up and running, I can log in to the admin-account but the admin-interface doesnt work any more and all I get is error messages like this:

"Warning:  [mysql error 1146] Table 'tillgr5_newpf.pf_lounge' doesn't exist

SELECT
    image_id
  FROM pf_lounge
; in /home/tillgr5/public_html/include/dblayer/functions_mysqli.inc.php on line 847


Fatal error: Uncaught Error: Call to a member function fetch_assoc() on boolean in /home/tillgr5/public_html/include/dblayer/functions_mysqli.inc.php:908 Stack trace: #0 /home/tillgr5/public_html/admin/include/functions.php(3273): query2array('\nSELECT\n ima...', NULL, 'image_id') #1 /home/tillgr5/public_html/admin.php(263): get_orphans() #2 {main} thrown in /home/tillgr5/public_html/include/dblayer/functions_mysqli.inc.php on line 908"

Is it a plug in doesent work with 12.1? But how do I disable this plugin with no admin-interface?

Offline

 

#2 2021-11-14 17:12:23

erAck
Only trying to help
2015-09-06
1219

Re: Admin-interface doesnt work after upgrade to 12.1

Looks more like your database is broken. There should be a table $prefixeTable.'lounge' (where $prefixeTable for you apparently is 'pf_' so 'pf_lounge').

Try to temporarily (!) add

Code:

$conf['check_upgrade_feed'] = true;

to your local/config/config.inc.php (remember that needs a leading <?php and a trailing ?> line) and point your browser to your site's upgrade_feed.php

Remove the config value from the config file after.


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2021-11-14 18:47:57

Tillgren
Member
2018-11-06
8

Re: Admin-interface doesnt work after upgrade to 12.1

Sorry, but this is way too technical and I don´t understand what to do.
Is the database corrupt due to the upgrade? Everything was working fine before the upgrade to 12.1

Offline

 

#4 2021-11-21 07:35:49

djom
Member
2015-05-24
13

Re: Admin-interface doesnt work after upgrade to 12.1

erAck wrote:

Looks more like your database is broken. There should be a table $prefixeTable.'lounge' (where $prefixeTable for you apparently is 'pf_' so 'pf_lounge').

Try to temporarily (!) add

Code:

$conf['check_upgrade_feed'] = true;

to your local/config/config.inc.php (remember that needs a leading <?php and a trailing ?> line) and point your browser to your site's upgrade_feed.php

Remove the config value from the config file after.

Hello erAck., I have exactly the same issue (upgrade to 12.1.0 failed and table piwigo_lounge missing) and trying to fix it, but in my case there is no config.inc.php in my local/config (howeber I do have a config_default.inc.php file in my include/ directory). Shall I create a local/config/config.inc.php file and put your 1-line code in it ?
Thanks for the help !

Last edited by djom (2021-11-21 07:44:14)

Offline

 

#5 2021-11-21 12:04:50

erAck
Only trying to help
2015-09-06
1219

Re: Admin-interface doesnt work after upgrade to 12.1

Either use [extension by Piwigo Team] LocalFiles Editor or create the file local/config/config.inc.php manually and in that case make sure you add the php tags as well (LocalFiles editor does that for you), not just the one line, so

Code:

<?php
$conf['check_upgrade_feed'] = true;
?>

Running Piwigo at https://erack.net/gallery/

Offline

 

#6 2021-11-21 18:15:01

paulleslie
Member
2015-03-09
9

Re: Admin-interface doesnt work after upgrade to 12.1

Hey - I just tried the fix. It worked! I'll put a comment back where you linked this post.

Thanks for your time. I very much appreciate it.

Offline

 

#7 2021-11-23 01:21:20

djom
Member
2015-05-24
13

Re: Admin-interface doesnt work after upgrade to 12.1

erAck wrote:

Either use [extension by Piwigo Team] LocalFiles Editor or create the file local/config/config.inc.php manually and in that case make sure you add the php tags as well (LocalFiles editor does that for you), not just the one line, so

Code:

<?php
$conf['check_upgrade_feed'] = true;
?>

Thank you, will give a try to "LocalFiles Editor" once I have managed to upgrade to 12.1.0.
I did a full backup just before the failed upgrade to 12.1.0 and asked my ISP to restore it.
So now I am back at version 11.5.0.
Now my question is : how to make sure the upgrade to 12.1.0 will not fail again ?
For info, I had 3 plugins activated: Embedded Videos. Extended Description and Physical2Virtual.
I also had 5 themes : Sylvia, clear, stripped, Stripped & Columns and dark (the one which was active was 'stripped').
What would you recommend to do ? Deactivate all plugins before retrying upgrade ?
I heard there is a 'manual upgrade' procedure, but not sure where it is. If it requires having ssh access to the server I won't be able to use it, I have only cPanel.

Any advice is welcome !

Here is what was shown during the failed upgrade:

Code:

Warning:  [mysql error 2006] MySQL server has gone away

TRUNCATE TABLE piwigo_user_cache_categories; in /home/choeu530/public_html/toutee.com/piwigo/include/dblayer/functions_mysqli.inc.php on line 864



Warning:  [mysql error 2006] MySQL server has gone away

TRUNCATE TABLE piwigo_user_cache; in /home/choeu530/public_html/toutee.com/piwigo/include/dblayer/functions_mysqli.inc.php on line 864


Warning: Cannot modify header information - headers already sent by (output started at /home/choeu530/public_html/toutee.com/piwigo/include/dblayer/functions_mysqli.inc.php:863) in /home/choeu530/public_html/toutee.com/piwigo/include/page_header.php on line 94

Fatal error: Uncaught --> Smarty: property 'literals' does not exist. <-- thrown in /home/choeu530/public_html/toutee.com/piwigo/include/smarty/libs/sysplugins/smarty_internal_extension_handler.php on line 92


Warning:  [mysql error 2006] MySQL server has gone away

REPLACE INTO piwigo_sessions
  (id,data,expiration)
  VALUES('4A38deu3u8fticunc3np2plln7r0k1','pwg_show_metadata|b:1;pwg_device|s:7:\"desktop\";pwg_mobile_theme|b:0;pwg_uid|i:1;',now())
; in /home/choeu530/public_html/toutee.com/piwigo/include/dblayer/functions_mysqli.inc.php on line 864

¸

And then later, when I tried to go admin, the error on the lounge table missing.

Last edited by djom (2021-11-23 01:25:23)

Offline

 

#8 2021-11-23 10:31:37

erAck
Only trying to help
2015-09-06
1219

Re: Admin-interface doesnt work after upgrade to 12.1

> Warning:  [mysql error 2006] MySQL server has gone away

That is a critical error, especially during upgrade, no wonder the upgrade failed. The connection between web server and MySQL server stopped. The cause may be anything from timeouts to insufficient memory. If it persists talk to your hoster.


> Deactivate all plugins before retrying upgrade ?

The upgrade process disables all plugins anyway.


Running Piwigo at https://erack.net/gallery/

Offline

 

#9 2021-11-24 04:45:18

djom
Member
2015-05-24
13

Re: Admin-interface doesnt work after upgrade to 12.1

erAck wrote:

> Warning:  [mysql error 2006] MySQL server has gone away

That is a critical error, especially during upgrade, no wonder the upgrade failed. The connection between web server and MySQL server stopped. The cause may be anything from timeouts to insufficient memory. If it persists talk to your hoster.


> Deactivate all plugins before retrying upgrade ?

The upgrade process disables all plugins anyway.

Thank you for the reply. I will see with Hostpapa if I can get temporarily extra memory and CPU units during the upgrade.
Is there any log file which would show when the upgrade failed ?

Offline

 

#10 2022-01-03 15:35:11

thepimster
Member
2016-06-22
3

Re: Admin-interface doesnt work after upgrade to 12.1

Hi erAck,

I have the same issue after upgrading to 12.1
So I added the line of code as you suggested, and pointed my browser to https://xxxxxxxx/upgrade_feed.php, where xxxxxxx is my website url.
But now I get the message 'upgrade feed is not active'
Sorry, newb here, hope you can help me further along.
Happy New Year!

Pim

Offline

 

#11 2022-01-03 15:58:07

thepimster
Member
2016-06-22
3

Re: Admin-interface doesnt work after upgrade to 12.1

So.... now it works.

Instead of pointing my browser to     .../upgrade_feed.php, I pointed it to .../upgrade.php
It told me I was still on 11.x and there was an upgrade availabe, so I ran the upgrade and now it works.
Afterwards removed the temporary '$conf['check_upgrade_feed'] = true;'

I should be good to go, thanks!

Pim

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact