Announcement

#1 2023-02-18 18:24:07

gioagr
Member
2022-12-16
5

smartalbum problem

Hi

the smartalbum plugin no longer works.

I tried uninstalling and reinstalling it, but nothing, when I go to create a new smart album it gives me these errors and it won't let me put the search filters...

Warning: Undefined array key "filters" in /web/htdocs/www.sitename.it/home/_data/templates_c/p6jhns^0effb54ca4ee1b8aadcb4810a7f01edac64acefa_0.file.album.tpl.php on line 386

Warning: Attempt to read property "value" on null in /web/htdocs/www.sitename.it/home/_data/templates_c/p6jhns^0effb54ca4ee1b8aadcb4810a7f01edac64acefa_0.file.album.tpl.php on line 386


and it won't let me put the search filters...

can you help me? 50% of my site works with smart albums

thanks

Offline

 

#2 2023-02-18 21:15:28

TOnin
Member
1970-01-01
106

Re: smartalbum problem

Hi, I don't know,
but let us guess, are you using Piwigo 13.5.0 in this bug report ?
Maybe can you provide other information about PHP, MySQL, ... etc (from your admin > tools > maintenance > environment page)

Offline

 

#3 2023-02-19 14:41:33

gioagr
Member
2022-12-16
5

Re: smartalbum problem

Piwigo 13.5.0 Controllo aggiornamenti
Installato il 30 Maggio 2022, 8 mesi 2 settimane 6 giorni fa
Sistema operativo: Linux
PHP: 8.0.27 (Mostra le informazioni) [2023-02-19 14:40:53]
MySQL: 5.6.51-91.0-log [2023-02-19 14:40:53]
Libreria grafica: ImageMagick 7.1.0-57

Thanks

Offline

 

#4 2023-02-19 15:30:40

erAck
Only trying to help
2015-09-06
2075

Re: smartalbum problem

Works here. If those warnings are displayed on screen, then either disable warning messages, or better log to file.
See [Forum, post 183126 by erAck in topic 31852] Menubar tags issue after 12.2.0 upgrade.


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2023-02-20 14:45:16

gioagr
Member
2022-12-16
5

Re: smartalbum problem

Hi, thanks for the answer, but unfortunately no, it doesn't work.

It is not possible to add the criteria (in my case the tags) to create the smart album.

The effect is that of having an album with all the photos on the site...

It's not just about the alerts, there's something that needs to be updated...

Offline

 

#6 2023-02-28 09:45:24

gioagr
Member
2022-12-16
5

Re: smartalbum problem

Anyone have the same problem?

Is there no solution?

Offline

 

#7 2023-03-08 10:34:48

vishap
Member
2023-01-02
6

Re: smartalbum problem

I had similar problems. I suspect they are compatibility issues related with the PHP version. I had to downgrade to 7.4.33 in order for the SmartAlbums to work properly.

Offline

 

#8 2023-04-21 22:02:44

rjpp
Member
2021-07-13
25

Re: smartalbum problem

vishap wrote:

I had similar problems. I suspect they are compatibility issues related with the PHP version. I had to downgrade to 7.4.33 in order for the SmartAlbums to work properly.

Had exactly the same issue and hadn't even considered PHP 8. Nice one, vishap!

Switched back to 7.4 (7.4.33) and SmartAlbum is working again.
My host tells me 7.4 is deprecated and that I should upgrade to a supported version - that will have to wait, a working SmartAlbum is more important to me.

Offline

 

#9 2023-04-22 01:31:56

erAck
Only trying to help
2015-09-06
2075

Re: smartalbum problem

Works for me, PHP 8.0.27, created filter for one tag and displaying only photos of that one tag. With warnings redirected to file as mentioned earlier.

And yes, PHP 7.4 is End-Of-Life, meaning it won't even receive any security fixes.


Running Piwigo at https://erack.net/gallery/

Offline

 

#10 2023-04-22 11:58:29

rjpp
Member
2021-07-13
25

Re: smartalbum problem

Oh. That moves the goal posts a touch.

I wouldn't mind having to redirect warnings but it just doesn't work as I can't select any tags at all on PHP 8.
Must be something else at play I suppose.

Offline

 

#11 2023-04-27 17:41:39

vishap
Member
2023-01-02
6

Re: smartalbum problem

Yes, the php 7.4 is deprecated, insecure and thus cannot be a long-term solution. I posted a request to include the smartalbums functionality into the main version of the piwigo: https://piwigo.org/forum/viewtopic.php?pid=186631. Hopefully it will find support among decision-makers.

Offline

 

#12 2023-04-30 10:55:52

TOnin
Member
1970-01-01
106

Re: smartalbum problem

Hi,
I reply from this environment :

environment wrote:

Piwigo 13.6.0 Dernière version ?
Installé le 11 Mai 2007, il y a 15 ans 11 mois 2 semaines 5 jours
Système d'exploitation: Linux
PHP: 8.0.27 (Montrer les informations) [2023-04-30 06:59:30]
MySQL: 10.5.19-MariaDB [2023-04-30 08:59:30]
Bibliothèque graphique: ImageMagick 7.1.0-62

Until recently I was using PHP 7.3.29 with no problem in crafting smartalbum albums, and piwigo 13.2 was displaying them.
After my system update, which lead me to PHP 8.0.27, and piwigo 13.6, the public display is still ok. As I did not pay much attention to them, I have not checked the details.

Getting deeper, I realize some of the smartalbum admin pages do not display the set of rules : that's true for smartalbum which have got, in table `pwg_category_filters`, `type` field set to `public_physical`, both `cond` and `value` set to NULL (also true for `type`==`permission` and `cond`==`public_physical` and `value`==NULL). I wonder why, could some previous hack broke something, or is it just the piwigo plugin updates. Need to investigate...

A brand new smartalbum, with rules displayed, does not show up in public gallery...
... well, and if I toggle between this config lines, the related admin page show or not the set of rules.

Code:

$conf['show_php_errors'] = E_ALL ;
$conf['show_php_errors'] = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_WARNING ;

On my host, piwigo.smartalbums code has not changed since 2022-06-05. I will give a look at https://github.com/Piwigo/Piwigo-SmartAlbums See you there !?

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact