Announcement

#1 2023-03-15 16:19:45

deWit-Johan
Member
2022-09-08
8

Albums not showing after update to 13.6.0

Hi all,

I just upgraded my Piwigo via the web UI to version 13.6.0.
But now my public albums are not shown any more. Only when I login as Admin I see my albums appear.
Visitors do not seen anything. All my albums are marked public

What might be the issue here? is there a know issue that I overlooked?

Edit1:I just found out it has to do with the plugin "GDThumb - 1.0.26". When I disable this (and enable another Gthumb+) that my visitor see my albums again.
So why is this GDThumb - 1.0.26 working fine whem I logied in as admin, but not when visitor look at my page?

Edit2:Forget Edit1 remark. Changing plugin does show some thumbs of albums, but not the picturesin the album. Furthermore the sizing of the thumbs is wrong. Something is definitly broken for my visitors.

Regards,
Johan


URL: http://https://fotos.familiedewit.net/

Last edited by deWit-Johan (2023-03-15 16:51:08)

Offline

 

#2 2023-03-15 19:43:11

erAck
Only trying to help
2015-09-06
2059

Re: Albums not showing after update to 13.6.0

I do see your photos in albums perfectly fine.


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2023-03-15 21:55:17

deWit-Johan
Member
2022-09-08
8

Re: Albums not showing after update to 13.6.0

erAck wrote:

I do see your photos in albums perfectly fine.

Well Yes and no. I'm still trying to figure out what is wrong. This is wat i learned:
I use the Bootstrap Darkroom Theme. This the recommends 2 plugins to handle thumbnails as mentioned in the description:
Quote:
Recommended plugins for best mobile experience:

* GThumb+ or gdThumb (for best "available screen space usage")
/UnQuote

So I use gdThumb. Worked perfect before piwigo 13.6.0. And still does when I login as Admin on my site and have the gdThumb plugin enabled. This how it is supposed to look:

https://familiedewit.net/posts/Post%201.jpg

But with this plugin enabled visitors doe not see anything.
Only when I disable the gdThumb plugin, and the Darkroom Theme reverts back to default behaviour, my visitor do see the thumbs again (this is wat you saw on my website).

https://familiedewit.net/posts/Post%202.jpg

But the looks and behaviour is not at all what I want.

So I think I should alter the title of my problem to "gdThumb plugin not working correctly anymore with Darkroom theme after upgrade to piwigo 13.6.0"

Any advice? I'm not an experienced piwigo user. Is there perhaps some logging that I could enable?

In the mean time I already did remove and reinstall the gdThumb plugin without any effect.

Regards,
Johan

Last edited by deWit-Johan (2023-03-15 22:09:47)

Offline

 

#4 2023-03-16 05:28:09

Katryne
Member
2016-12-03
377

Re: Albums not showing after update to 13.6.0

You may try the other recommended plugin Gthumb+. It's the one I use with Bootstrap Darkroom on Piwigo 13.6.


http://photos.katrynou.fr/ v.14.1.0 https://album.chauvigne.info/ v.13.8.0
Système d'exploitation: Linux - Hébergeur 1&1-Ionos PHP: 8.0.28 - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

Offline

 

#5 2023-03-16 09:51:24

deWit-Johan
Member
2022-09-08
8

Re: Albums not showing after update to 13.6.0

Katryne wrote:

You may try the other recommended plugin Gthumb+. It's the one I use with Bootstrap Darkroom on Piwigo 13.6.

Thanks for the respons, sure I could switch to that one, or stay with the default behavior. But I do like the functionality of the gdThumb plugin. And it does not really answer the question why it stopped working.

Offline

 

#6 2023-03-16 18:25:27

deWit-Johan
Member
2022-09-08
8

Re: Albums not showing after update to 13.6.0

deWit-Johan wrote:

Katryne wrote:

You may try the other recommended plugin Gthumb+. It's the one I use with Bootstrap Darkroom on Piwigo 13.6.

Thanks for the respons, sure I could switch to that one, or stay with the default behavior. But I do like the functionality of the gdThumb plugin. And it does not really answer the question why it stopped working.

Actually just tested as mentioned the Gthumb+ plugin and that one too has errors! It obnly show the thums in the albums and subalbums, but it does not show the actual photos

Please advice!

Regards,
Johan

Offline

 

#7 2023-03-17 16:04:45

deWit-Johan
Member
2022-09-08
8

Re: Albums not showing after update to 13.6.0

So I finally worked out what was causing my problems after the update. It was another plugin "rightClick" v2.10.a.

With the develop tools enabled in Edge I noticed an error whenever I looked at my page as visitor. This error does not appear when I'm logged in.
What the plugin does is prevent richt click menu for visitors, not for Admins!

Seems there is some problem with piwigo 13.6.0!

Error thrown:
Uncaught SyntaxError: Unexpected token '<' (at picture.php?/367/category/11:401:1)

And when I open the source window this line is marked red:

<!-- Protected images by the "rightClick" plugin (version <br />
<b>Warning</b>:  Undefined array key "Version" in <b>/home/deb48734/domains/familiedewit.net/public_html/fotos/_data/templates_c/1gr9sf2^eddbd842063198dbaac14af9101538faba52d67b_0.file.rightClick_protect.tpl.php</b> on line <b>33</b><br />

Disabling this plugin solved my issues! (But now richt click menus is enabled in the browser.)
Also gdThumb plugin working fine now.

Last edited by deWit-Johan (2023-03-17 16:06:17)

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact