Announcement

  •  » Extensions
  •  » Prepaid Credits plug-in not working

#1 2023-10-01 11:50:50

lonjazurbaran
Member
2023-10-01
7

Prepaid Credits plug-in not working

Hi, community. I've just installed a Piwigo (13.8 version / Modus theme) with some galleries and 'Prepaid Credits' plug-in.

Plug-in correctly configured. It's really clear and easy.

Now, when a user pays for credits, the money arrives ok to Admin paypal account. Instantaneously. That's great.

But the user never get the credits (the message: "...No worry! Buy more credits on your profile page..." appears again and again) and his wallet keeps at 'zero'.

Can anybody figure out what am I doing wrong?





______
Environment

    Piwigo 13.8.0
    Installed on 27 September 2023
    Operating system: Linux
    PHP: 8.0.28
    MySQL: 10.6.12-MariaDB-cll-lve
    Graphics Library: ImageMagick 7.1.0-20
    Cache size 18.57 Mo

Activated plugin list 1

    Prepaid Credits

Offline

 

#2 2023-10-02 09:46:41

lonjazurbaran
Member
2023-10-01
7

Re: Prepaid Credits plug-in not working

Just reinstalled a fresh Piwigo (13.8) with nothing else but this plug-in and, again, users can pay for the credits but after paying, no credits appear in their accounts ("...0 credits left...") again and again...

I'm desperate

any help?

Offline

 

#3 2023-10-02 10:20:09

erAck
Only trying to help
2015-09-06
1958

Re: Prepaid Credits plug-in not working

Does the payment process when returning from Paypal display any error or warning messages? Anything plugin related in PHP error logs, if you happen to log things? See [Forum, post 180778 by erAck in topic 31258] Error Message for how to setup a local to Piwigo PHP logging.


Running Piwigo at https://erack.net/gallery/

Offline

 

#4 2023-10-02 11:29:17

lonjazurbaran
Member
2023-10-01
7

Re: Prepaid Credits plug-in not working

Thanks a lot, erAck, for your reply.

At first sight, there's no error message at all. No special message displays.

The customer clicks on 'buy credits', which redirects to Paypal, then they make the payment without any problem and automatically that money comes to my Paypal account.

So that seems to work flawlessly.

But, when the user comes back to the gallery, there's no such credits in her account. Just 'Zero' credits.

I get my money but he doesn't get his credits.

:-(

Offline

 

#5 2023-10-02 12:25:44

erAck
Only trying to help
2015-09-06
1958

Re: Prepaid Credits plug-in not working

I don't know if it would lead to anything, but you might want to submit an issue at https://github.com/plegall/piwigo-prepa … its/issues


Running Piwigo at https://erack.net/gallery/

Offline

 

#6 2023-11-12 20:22:20

lonjazurbaran
Member
2023-10-01
7

Re: Prepaid Credits plug-in not working

Offline

 

#7 2023-11-12 22:42:01

erAck
Only trying to help
2015-09-06
1958

Re: Prepaid Credits plug-in not working

See [Github] piwigo-prepaid-credits issue #9 for ongoing issue discussion.


Running Piwigo at https://erack.net/gallery/

Offline

 

#8 2023-12-16 23:14:13

lonjazurbaran
Member
2023-10-01
7

Re: Prepaid Credits plug-in not working

Last Piwigo 14 version recently released doesn't seem to fix this problem either...

It's so frustrating

Offline

 

#9 2023-12-17 14:20:44

erAck
Only trying to help
2015-09-06
1958

Re: Prepaid Credits plug-in not working

It's a plugin, so of course a core update does not fix anything in that plugin..


Running Piwigo at https://erack.net/gallery/

Offline

 
  •  » Extensions
  •  » Prepaid Credits plug-in not working

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact