Announcement

#16 2023-12-21 21:26:11

ketchemr
Member
2020-08-07
16

Re: Piwigo 14

ketchemr wrote:

Unfortunately, my update broke and I had to restore my files and db. Not sure what happened. I will try again with a later version.
Make sure you have a backup of files and db before upgrading, as the upgrader warns!

I downgraded PHP from 8.1 to 8.0 and the update from 13.8.0 to 14.0.0 ran smoothly. I had to set Bootstrap Darkroom as the theme after the update and turn on all of my plugins, but all else was fine.

Last edited by ketchemr (2023-12-21 21:28:53)

Offline

#17 2023-12-22 09:59:19

deemon
Member
2021-05-03
45

Re: Piwigo 14

Upgrading 13.8.0 to 14.0.0:
In admin -> upgrade page, some warning that some extensions and theme is out of date.

[v] Upgrade anyway

ended with:
Warning: array_map() expects parameter 1 to be a valid callback, function 'smarty_ucfirst_ascii' not found or invalid function name in /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 768

Warning: implode(): Invalid arguments passed in /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 769

Fatal error: Uncaught Error: Call to undefined function smarty_strtolower_ascii() in /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_method_loadplugin.php:63 Stack trace: #0 /var/www/html/galerii/include/smarty/libs/Smarty.class.php(1024): Smarty_Internal_Method_LoadPlugin->loadPlugin(Object(Smarty), 'smarty_function...', false) #1 /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(822): Smarty->loadPlugin('smarty_function...', false) #2 /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(1610): Smarty_Internal_TemplateCompilerBase->getPlugin('private_print_e...', 'function') #3 /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(550): Smarty_Internal_TemplateCompilerBase->compileTag2('private_print_e...', Array, Array) #4 /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_templateparser.php(2130): Smarty_Internal_TemplateCompilerBase->compileTag('private_pri in /var/www/html/galerii/include/smarty/libs/sysplugins/smarty_internal_method_loadplugin.php on line 63


After that reloading admin.php (with removing all the variables from the url) was redirected to upgrade.php, which apparently worked:

Upgrade from version 13.0.0 to 14.0.0
Statistics

    total upgrade time : 1.963 s
    total SQL time : 1.929 s
    SQL queries : 30

Upgrade information

    As a precaution, the following plugins have been deactivated. You must check for upgradable plugins before reactivating them:

    AdditionalPages, Fotorama, PersoFavicon, log_failed_logins, check_uploads



After that the page worked fine, except with default theme + no plugins. And after upgrading the plugins and theme also, and activating them, it was back to normal. So in the end upgrade seems to have worked. But it was FAR from flawless for me, in contrast what others have written here.

Last edited by deemon (2023-12-22 10:20:22)

Offline

#18 2023-12-25 20:36:00

executive
Member
2017-08-16
1216

Re: Piwigo 14

@deemon
Please read two messages above yours

Offline

#19 2023-12-27 03:15:59

timoteo
Guest

Re: Piwigo 14

Running Piwigo 14.0.0 on a Siteground subdomain with PHP 8.2.13. Initially, I added albums and photos and everything worked fine.

Now, when I attempt to add a new album, I get the dialog box to add it and then after naming the album, I click ADD and the button goes from orange to light orange but nothing happens - the dialog box does not go away and the album is not created. Any thoughts?

#20 2023-12-27 09:17:31

executive
Member
2017-08-16
1216

Re: Piwigo 14

@timoteo please see my previous comment

Offline

#21 2023-12-27 20:51:06

Deleuze
Member
2023-10-14
2

Re: Piwigo 14

Deleuze wrote:

I was wondering whether Piwigo 14 would work with PHP 8.3, too? If it currently does not, is it going to anytime soon?

plg wrote:

As far as we have tested, no problem with PHP 8.3.

Thanks a lot for your feedback @plg, appreciated!

Offline

#22 2024-04-26 06:25:11

doggy
Member
2016-12-27
4

Re: Piwigo 14

Weird. I've had Piwigo for many years and always happy with it.
Great Product.

However, I can only get Piwigo 14.3 or 14.4 to work properly with PHP 7.4 (or 7.3).

With PHP 8.1 I get 500 errors everywhere and cannot access my piwigo website.

For reference I have in my .htaccess:

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php74” package as the default “PHP” programming language.
<IfModule mime_module>
  AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
WORKS

but the following does not work:

# php -- BEGIN cPanel-generated handler, do not edit


# Set the “ea-php81” package as the default “PHP” programming language.
<IfModule mime_module>
  AddHandler application/x-httpd-ea-php81 .php .php8 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

Here's a snippet of one 500 error, but there are hundreds of them:

"GET /picture.php?/5761/category/332 HTTP/2.0" 500 -

Does anyone have any clues? This is on an inmotionhosting shared server not that I think that is particularly relevant. php 8.1 is working on heaps of other things (like Joomla) on my server, only exception is piwigo.

Last edited by doggy (2024-04-26 06:26:46)

Offline

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact