Announcement

#1 2020-06-17 04:42:21

tkrn
Member
2020-04-16
6

Long AJAX Scripts Running?

Hey all -

I'm having an issue with my installation of Piwigo. It appears to be a long running JavaScript AJAX commands. Please see the screenshot. It appears the actual transfer from the webserver is rather quick but the requests that include ?ajaxload=true are the problem entries.

http://tkrn.io/u/tkrn/2020-06-16_22-34-04.png

Piwigo 2.10.2 Check for upgrade
Operating system: Linux
PHP: 7.4.3 (Show info) [2020-06-16 21:31:32]
MySQL: 10.2.31-MariaDB-log [2020-06-16 21:31:32]
Graphics Library: External ImageMagick 6.7.8-9

Link to Piwigo Installation: https://g.tkrn.io

Offline

 

#2 2020-06-17 18:15:40

erAck
Only trying to help
2015-09-06
1415

Re: Long AJAX Scripts Running?

The only occurrences of ajaxload I see in the source code is when derivatives are to be retrieved. May it be that it happens only if derivatives or thumbnails of an album in a specific size are not cached already and that it takes longer the more images are in an album?


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2020-06-18 04:04:00

tkrn
Member
2020-04-16
6

Re: Long AJAX Scripts Running?

erAck - Thanks for the nugget of direction. I installed Batch Manager and did a batch generation on a size thumbnail that wasn't standard. This has resolved the issue. It must have been generating those thumbnails sizes (e520) on the fly. All resolved now. Thanks!

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact